Requirements

To build blue, the following programs are used:

Java Development Kit 1.7+

Contains javac java compiler and other development tools.

Netbeans 8.0

The Netbeans IDE is used to develop Blue. It is recommended to use Netbeans for compiling and developing the program. It is available at http://www.netbeans.org.

Apache Ant

Ant is build tool for Java projects. It is available at http://ant.apache.org. This is required if building from the commandline.

JUnit

JUnit is required to run the unit tests and is integrated as part of the build.

xsltproc, Apache FOP, Sun JAI library

xsltproc is used to build all versions of the manual. To build the PDF manual, Apache FOP and Sun JAI library are required.